Jump to content


Photo

F1 2011 on PC


  • Please log in to reply
23 replies to this topic

#1 ProjektONE

ProjektONE

    Member

  • Members
  • PipPip
  • 22 posts

Posted 30 September 2011 - 08:27 PM

Has this been released on PC? I've looked everywhere and am not able to find it.

#2 capchaos

capchaos

    Member

  • Members
  • PipPip
  • 14 posts

Posted 30 September 2011 - 09:07 PM

You can buy it through steam

#3 left888

left888

    Super Member

  • Members
  • PipPipPipPipPipPip
  • 716 posts
  • LocationMedicine Hat, Alberta

Posted 01 October 2011 - 01:59 AM

I bought it on Steam, it's a lot of fun but so many bugs. Frame rate problems as well, but that's Codemasters for you.
|i7 960@3.20Ghz|6 Gigs Ram|WIN 7 64bit|2 GeForce SLI|GTX670|Sam Maxwell Momo Mod 26C Wheel|DSD Track Boss Button Box|
|3 LCD HDTV55"@5670x1080|Custom ZALEM Frame|Thrustmaster T500 with reverse mounted Fanatec Club Sport Pedals|DSD Pro Sequential Shifter|

Check out my rig HERE
darrenmckenna.com

#4 Skeil

Skeil

    Member

  • Members
  • PipPip
  • 26 posts
  • LocationDecatur, Ga

Posted 01 October 2011 - 08:21 AM

I have it and love it, and I haven't even really notice the quirks yet, because I have so much fun playing.

#5 wizard88

wizard88

    Advanced Member

  • Members
  • PipPipPip
  • 50 posts
  • LocationEngland U.K

Posted 01 October 2011 - 11:34 AM

I BOUGHT MINE ON EBAY AND HAVE ONLY REALLY SCRATCHED THE SURFACE BUT I WILL LOVE IT BEEN A F1 NUT!!! :lol:
Follow Your Dreams !!!!


#6 PAPA

PAPA

    Super Member

  • Members
  • PipPipPipPipPipPip
  • 890 posts
  • LocationSouth Wales UK

Posted 01 October 2011 - 11:56 AM

It's a tad annoying.... Have to set my wheel up every time grrrrrrr and says I'm not signed into live and says no network connection. Hope they patch this problem.

Other then that liking it so far ;) I find it much harder then the last one but that's a good thing.

Daz
Posted Image

I think of you all as friends but if zombies chase us I'm tripping you !

Joke ......... Two cannibals were eating a clown, One says to the other, does this taste funny to you?"



He who dies with the most toys wins..
XBL = FCTAFF

#7 Okoe Dokie

Okoe Dokie

    Expert Member

  • Members
  • PipPipPipPipPip
  • 255 posts

Posted 01 October 2011 - 02:13 PM

F1 2011 like F1 2010 is a direct port (add some directx11 support) from the console version which have better CPU than GPU. Thus the PC version works your CPU more than your GPU even for graphics (especially track reflection on) .

#8 left888

left888

    Super Member

  • Members
  • PipPipPipPipPipPip
  • 716 posts
  • LocationMedicine Hat, Alberta

Posted 01 October 2011 - 03:16 PM

It's a tad annoying.... Have to set my wheel up every time grrrrrrr



Do not touch the keyboard until after the screen loads, use the start button on your wheel. This is same issue that is in Dirt 3. Then after the screen loads your saved setting from last time can be used.
|i7 960@3.20Ghz|6 Gigs Ram|WIN 7 64bit|2 GeForce SLI|GTX670|Sam Maxwell Momo Mod 26C Wheel|DSD Track Boss Button Box|
|3 LCD HDTV55"@5670x1080|Custom ZALEM Frame|Thrustmaster T500 with reverse mounted Fanatec Club Sport Pedals|DSD Pro Sequential Shifter|

Check out my rig HERE
darrenmckenna.com

#9 left888

left888

    Super Member

  • Members
  • PipPipPipPipPipPip
  • 716 posts
  • LocationMedicine Hat, Alberta

Posted 01 October 2011 - 03:22 PM

I enjoy this game a lot on the PC, getting flagged while on the starting grid is frustrating. Lots of these errant flags for no reason, sometimes my nose gets torn off and my crew chief has gone for a nap and does not notice. I can run the graphics on ultra on my i7 with 8 gigs of ram but reflections must be turned to low or they drain the lifeblood out of the game.
|i7 960@3.20Ghz|6 Gigs Ram|WIN 7 64bit|2 GeForce SLI|GTX670|Sam Maxwell Momo Mod 26C Wheel|DSD Track Boss Button Box|
|3 LCD HDTV55"@5670x1080|Custom ZALEM Frame|Thrustmaster T500 with reverse mounted Fanatec Club Sport Pedals|DSD Pro Sequential Shifter|

Check out my rig HERE
darrenmckenna.com

#10 PAPA

PAPA

    Super Member

  • Members
  • PipPipPipPipPipPip
  • 890 posts
  • LocationSouth Wales UK

Posted 01 October 2011 - 03:42 PM

I run everything flat-out and have not noticed any slow down.
Posted Image

I think of you all as friends but if zombies chase us I'm tripping you !

Joke ......... Two cannibals were eating a clown, One says to the other, does this taste funny to you?"



He who dies with the most toys wins..
XBL = FCTAFF

#11 left888

left888

    Super Member

  • Members
  • PipPipPipPipPipPip
  • 716 posts
  • LocationMedicine Hat, Alberta

Posted 01 October 2011 - 10:45 PM

I run everything flat-out and have not noticed any slow down.


What do you have for a computer?
|i7 960@3.20Ghz|6 Gigs Ram|WIN 7 64bit|2 GeForce SLI|GTX670|Sam Maxwell Momo Mod 26C Wheel|DSD Track Boss Button Box|
|3 LCD HDTV55"@5670x1080|Custom ZALEM Frame|Thrustmaster T500 with reverse mounted Fanatec Club Sport Pedals|DSD Pro Sequential Shifter|

Check out my rig HERE
darrenmckenna.com

#12 left888

left888

    Super Member

  • Members
  • PipPipPipPipPipPip
  • 716 posts
  • LocationMedicine Hat, Alberta

Posted 02 October 2011 - 12:05 AM

It's a tad annoying.... Have to set my wheel up every time grrrrrrr


Do not touch the keyboard until after the screen loads, use the start button on your wheel. This is same issue that is in Dirt 3. Then after the screen loads your saved setting from last time can be used.



Papa, have you tried this and if so did it work for you?
|i7 960@3.20Ghz|6 Gigs Ram|WIN 7 64bit|2 GeForce SLI|GTX670|Sam Maxwell Momo Mod 26C Wheel|DSD Track Boss Button Box|
|3 LCD HDTV55"@5670x1080|Custom ZALEM Frame|Thrustmaster T500 with reverse mounted Fanatec Club Sport Pedals|DSD Pro Sequential Shifter|

Check out my rig HERE
darrenmckenna.com

#13 PAPA

PAPA

    Super Member

  • Members
  • PipPipPipPipPipPip
  • 890 posts
  • LocationSouth Wales UK

Posted 02 October 2011 - 04:17 AM

Hi m8

No I have not tried it yet, I'll give it a go today.

I run a watercooled i7 Bloomfield over clocked to 4.02Ghz and a overclocked 6970 2048mb and 3x4GB ddr3 1600Mhz triple channel ;) runs everything on f1 at it's highest settings no problems ;)

Daz
Posted Image

I think of you all as friends but if zombies chase us I'm tripping you !

Joke ......... Two cannibals were eating a clown, One says to the other, does this taste funny to you?"



He who dies with the most toys wins..
XBL = FCTAFF

#14 left888

left888

    Super Member

  • Members
  • PipPipPipPipPipPip
  • 716 posts
  • LocationMedicine Hat, Alberta

Posted 02 October 2011 - 08:04 AM

Similar to my system but I have more ram (triple channel) but my cpu is not overclocked. i7 960 3.2Ghz and a geforce gtx 570 I am using a 55" Sony Bravio for a screen. With all the settings in F1 on ultra my system worked perfect, then I think there was a steam update and my frame rate remained the same after another benchmark, however the screen was choppy. So after a little research I found if I turned reflections down it worked like a champ. I will keep looking to see what I can come up with.

cheers
Darren
|i7 960@3.20Ghz|6 Gigs Ram|WIN 7 64bit|2 GeForce SLI|GTX670|Sam Maxwell Momo Mod 26C Wheel|DSD Track Boss Button Box|
|3 LCD HDTV55"@5670x1080|Custom ZALEM Frame|Thrustmaster T500 with reverse mounted Fanatec Club Sport Pedals|DSD Pro Sequential Shifter|

Check out my rig HERE
darrenmckenna.com

#15 PAPA

PAPA

    Super Member

  • Members
  • PipPipPipPipPipPip
  • 890 posts
  • LocationSouth Wales UK

Posted 02 October 2011 - 10:49 AM

I use three screens do not know if that makes a difference.

Daz
Posted Image

I think of you all as friends but if zombies chase us I'm tripping you !

Joke ......... Two cannibals were eating a clown, One says to the other, does this taste funny to you?"



He who dies with the most toys wins..
XBL = FCTAFF

#16 left888

left888

    Super Member

  • Members
  • PipPipPipPipPipPip
  • 716 posts
  • LocationMedicine Hat, Alberta

Posted 03 October 2011 - 04:37 PM

Today I set all the settings on ultra except for the reflections, turned it to medium and it works very well. Not sure either if a large monitor will effect frame rate. Papa, did you try the keyboard bypass for your wheel save yet?
|i7 960@3.20Ghz|6 Gigs Ram|WIN 7 64bit|2 GeForce SLI|GTX670|Sam Maxwell Momo Mod 26C Wheel|DSD Track Boss Button Box|
|3 LCD HDTV55"@5670x1080|Custom ZALEM Frame|Thrustmaster T500 with reverse mounted Fanatec Club Sport Pedals|DSD Pro Sequential Shifter|

Check out my rig HERE
darrenmckenna.com

#17 ProjektONE

ProjektONE

    Member

  • Members
  • PipPip
  • 22 posts

Posted 08 October 2011 - 02:06 PM

Finally bought the game from Microsoft Live but the friggin thing doesnt load, it shows the F1 2011 Banner then it sits there!. Looks like I need to start troubleshooting it. UGH!!!

#18 LoG LaB 76

LoG LaB 76

    Member

  • Members
  • PipPip
  • 18 posts
  • LocationSwitzerland

Posted 04 November 2011 - 03:40 PM

HI Racers i have huge Problems with F1
1. At Beginnig was everything ok,dont know what i did, but now my game starts always in a Window with small Res 800x600 or so ....if i strech the Screen the game Runs in 40-60 FPS no Problems !!!But i have the Windows Bar on Top ,i hate it! but at least Playable

But as soon i switch to Fullscreen ALT+Enter ,change Settings to 5760x1080 Somethings Wrong...the Game runs only on 20 fps!
And the Image what before always Showing everything on 3 Screens ,now it Shows Beginning Trailer, Pit - Garage all just on one Screen !!! in Car again on three20FPS ! that wasnt before!

And now Yesterday id Start it and was a Update to Do Windows live or xbox sign in!!! since then it crashed 3 Times after Live Sign in and Today it dont even Starts at all.

Repairing it right now! hope works!!! ..............no did not...at least it Starts Again but crashes always when Checking Saving Devices ....no Problems at all with other Games !!!

#19 LoG LaB 76

LoG LaB 76

    Member

  • Members
  • PipPip
  • 18 posts
  • LocationSwitzerland

Posted 07 November 2011 - 09:10 AM

So...Wanna add F1 works again after, uninstall & reinstall it,off course my Data s gone!!!
Still Problem with Fullscreen
Had a Problem with F1 2010 on Xbox too last Year,my data just was gone and i had a real good Season, things like that are really frustrating...setups all gone ,but i think i have a Problem with my Version or Disc! gonna try Customer Helpline

#20 TigerBlueGamer

TigerBlueGamer

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 14 November 2011 - 08:08 PM

It's a tad annoying.... Have to set my wheel up every time grrrrrrr



Do not touch the keyboard until after the screen loads, use the start button on your wheel. This is same issue that is in Dirt 3. Then after the screen loads your saved setting from last time can be used.

I don't have a start button on my wheel. Will try not pressing any keys on the keyboard and will try the buttons on my wheel instead.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users